KNOWLEDGEBASE    |    Database
  • thumb_up
  • thumb_down
Article ID: 217

Setting the RabbitMQ service logging parameters

Problem


The RabbitMQ log grows very large over a short period of time.

 

Cause


The default behavior of RabbitMQ logging is to record various warnings, connection information and errors. This results in a log that grows very quickly.

 

Solution


Configure the RabbitMQ service to record only errors in the log by modifying the rabbitmq.config file. This will save space and will make the logs more managable. The steps are shown below.

1. In the c:\programdata\retailpro\server\rabbitMQ folder edit the rabbitmq.config file. Its initial contents will just be []. Replace this contents with :

[
    {rabbit, [{log_levels,[{connection, error}]}]}
].

2. Save the file.
3. Stop the RabbitMQ service through Windows Service manager (shown below).

 

4. Delete the existing RabbitMQ logs in the C:\programdata\RetailPro\server\rabbitMQ\log
5. Restart your Prism Server.


The RabbitMQ service will now only record errors that occur.