Incorrect assignment of AppCard rewards when changing customers on transaction
Incorrect assignment of AppCard rewards when changing customers on transaction
Problem
During a transaction, a cashier begins the transaction with Customer 1, assigns them in the AppCard User Identification screen, and continues with the transaction. The cashier then changes the customer on the Retail Pro transaction to Customer 2. When the transaction is completed, the cashier learns that Customer 1 earned the loyalty rewards rather than Customer 2.
Cause
Changing the customer on the Retail Pro transaction will not change the customer assignment in AppCard. A cashier can only assign a customer in the AppCard User Identification screen once during a transaction.
If you attempt to select the AppCard Rewards button a second time during the transaction, you'll notice that you do not have the option to change the phone number [or customer] in AppCard.
Solution
If a cashier needs to change which customer is earning or redeeming loyalty points through the AppCard portal during a transaction, the cashier must cancel the current transaction and begin a new Retail Pro transaction.
Note: there is no validation between the customer assigned to the Retail Pro transaction with the AppCard user identification (or loyalty card).