Procedure to Reset the V8 TRZC Plug-in Database

Problem:
Corrupted Tax Rate By Zip database
Symptom:
Ship To customer tax rate is not applied to the document when a customer with a qualifying address is added. 
Cause:
A corrupted Tax Rate By Zip database can happen for a number of reasons the most common causes are 
  1. Upgrade from the 8.52 version of the Tax Rate by Zip plug-in  
  2. Application of both the Canadian and U.S. tax changes to the same installation.
Solution:
Re create the TRZC database. Below are the instruction for recreating a U.S. TRZC database.
1. Locate the [drive]:Retail8\RPRO\TRZC folder and rename it to TRZCOLD
2. Browse to the following folder
  [drive]:\Retail8\TaxAreaMaintenance\ and run TaxRateMaintenance.exe
3. Go to the STATES tab (confirm it is blank).
4. Go to the PREFERENCES tab and set the appropriate settings based the client requirements (note if this is a US installation do not turn on the "Canada Tax" setting)
5. Go to the DATABASE tab  
6. Locate the update file using the path field. 
  EG; [drive]:Retail8\TaxAreaMaintenance\TaxDataUSDec2013.txt
7. Locate the changes file using the path field 
  EG:  [drive]:Retail8\TaxAreaMaintenance\DecCHANGES.txt
8. Click the UPDATE button
9. Answer YES to the prompt asking whether the database has been backed up.
--When the zip codes and tax rates have finished importing continue with the following:
10. Go to the STATES tab Locate the STATES in the US where have a presence. Change them to Y under the SELECT column (and SHIP tax and Repairs if appropriate)
11. Move off of each state's row once you have made the setting described above to ensure that the change is applied.
12. Got to the TAX RATES Tab and add any exceptions per the customer's requirements.
EXIT

Published on Mar 18, 2014 in Plugins & Integrations

 

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