Cannot connect to Oracle using Retail Pro 9 on systems using AVAST Anti-Virus

Symptom

Error attempting to connect to Oracle on systems running AVAST Anti-Virus. License server will not start and you will see a blank error dialog running the service manager.

Cause

AVAST Anti-Virus on access scanner is erroneously detecting Oracommon11.dll as a virus under its May 15th virus definitions and is moving the file to a protected area.

Solution

Restore the file and add it to the exclusions list.

Procedure

  1. In the AVAST software locate the "STATISTICS" panel and go the "COMPONENT STATUS" page.
  2. Click on the "ITEMS STORED IN THE VIRUS CHEST" link.
  3. Locate the file "[drive]:\oracle\ods11gr1\bin\oracommon11.dll" or [drive]:\oracle\ods11gr1cli\bin\oracommon11.dll", right click on the file and choose "RESTORE AND ADD TO EXCLUSIONS"

Additional Information

Please also see the following KB article on anti virus configurations. http://partners.retailpro.com/Support/Knowledgebase.php?a=

Published on Mar 18, 2014 in Oracle

 

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