Error launching the Technician's Toolkit from workstation following an upgrade to Retail Pro 9.4

Problem

A retailer has upgraded to Retail Pro 9.4 but has not yet installed the Oracle 12c client on the Retail Pro workstation(s).

Symptom(s)

While launching the Technician's Toolkit from a client only Retail Pro workstation, the user receives an "Oracle SID not found" error and also the Database field will be blank with no options in the database drop-down. 

Pictire of the Oracle SID error message

Picture of the system log on screen with the database field showing blank

Cause

The workstation is using the Oracle 11g database instead of the Oracle 12c database.

Solution

Short Term Solution / Workaround: Type in "RPROODS" into the Database field (see below) and then select the "OK" button. 

Permanent Solution: Install the Oracle 12c client using the 9.40 installation image. 

Picture of the Tech Toolkit dialog window showing the word RPROODS in the database field

Published on Jun 28, 2018 in Technical Bulletin, Errors

 

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