Access Violation while attempting to access the Technician's Toolkit (offline)
Access Violation Error while attempting to access the Technicians Toolkit while offline (from database).
This article discusses troubleshooting steps to perform if the user receives an Access Violation error (image shown below) while attempting to access the Technician's Toolkit in Retail Pro 9. This can occur when accessing the Technician's Toolkit in "offline mode" (I.e. disconnected from the database).
Symptom
The user is met with the following (or similar) error message while attempting to log into the Technicians Toolkit in order to perform recovery operations.
Cause
The offline security file (Dbsec.dat) being used is corrupted or had been created from a different version of Retail Pro 9, and therefore will not work.
Solution
Create a new offline security file on another system running the same version of Retail Pro 9 and place it into the \RetailPro9 folder of the offline installation.
Note: A Dbsec.dat file generated from any 9.30.XXX.XXX installation can be used on any build of 9.30. Likewise Dbsec.dat file generated from any 9.40.XXX.XXX installation can be used on any build of 9.40.
Recommendation
Any time you upgrade a customer from one version to another you should create a new offline security file. Follow the link below for instructions on how to create an offline security file.
http://partners.retailpro.com/Support/Knowledgebase.php?a=148