Troubleshooting Unresponsive Genius Device in Retail Pro Prism
The Genius device is the wired pin pad used to process Credit/Debit and gift cards through Global Payments Integrated.
This TechByte is specific to Cayan and the Genius device, as Adyen or Payone may not exhibit the same symptom. The configuration method used to correct the problem would be completely different as well, as the devices themselves are different for other EFT integrations.
Problem
The Genius device is unresponsive while tendering a document by credit card
Symptoms
- "Waiting on Device" Dialog never completes the hand off to the Pin Pad.
- Reviewing the Developer Tools window (F12) Network tab of the browser you will notice that there are repeated attempts to connect (similar to the ones shown below)
- Upon closer inspection you will find that each of the failed entries contain a message similar to the one shown below.
Cause
This is caused by an incorrect IP definition in the HAL of the workstation's Proxy. This can be due to either the IP having changed due to the DHCP or incorrectly applied to the configuration initially.
Solution
- Verify the IP on the Genius device
- Ensure a Static IP on the Genius device
- Assign the IP correctly the HAL.
Steps
Verify IP on the Genius
- At the Genius idle screen, press ‘0' on the keypad three times
- Enter password: 9416557 - Press Enter
- IP information will be visible
Configure Genius for a Static IP
- At the Genius idle screen, press the 1, 5, 9 keys at the same time
- Enter password: 166832 - Press Enter
- Select the Administration tab
- Select the Communication tab
- Select the Network tab
- Select the Ethernet tab
- Tap the Pencil next to Mode
- Select Static IP and press OK
- Tap the pencil next to each option, and fill in the necessary Static IP information
- Tap Apply to save the changes
- Select the Home tab
- Tap the Run App icon to return to the idle screen
Assign Genius IP Correctly in HAL
- Open RP Prism
- Go to Administration Console > Node Selection and locate your workstation
- Edit the HAL settings of the workstation hosting the Genius device.
- Save your changes
- Restart the Proxy