Importing Legacy Reports into Retail Pro Reporting
Problem
After deploying Retail Pro Reporting for a customer, you may notice that some reporting modules you had been familiar with are no longer available in this version. You may plan to reinstall or move an installation of Retail Pro Reporting from one machine to the other but seem to be missing custom or default reports that were previously available.
Cause
Reports for Retail Pro products are not automatically included with every installer and may or may not be immediately available on first installation.
Solution
To remedy this, please visit the Retail Pro Reporting page on My Retail Pro and download any legacy reports that have been available in previous releases of Retail Pro Reporting.
If this is for an existing installation, be sure to back up your reports using the method that follows before reinstalling or moving a Retail Pro Reporting installation to a new machine. This will preserve legacy and custom reports that may be in use at that location.
To back-up reports before moving an installation or to share with another installation
1: Log into Retail Pro Reporting as the administrator_user used to register your license.
2: Expand the menu on the left and select ‘Maintenance'
3: Select the reports you are interested in backing up and press ‘Export'
4: Save the file.krr to a location as a backup or share with other installations.
To import reports in a new or existing Retail Pro Reporting installation
1: Referencing the above image, select ‘Import.'
2: Select Browse and select a previously saved .krr file, or download an available set from the Retail Pro Reporting page on My Retail Pro.
3: Assign a reports owner. By default, this will be the email associated with the key.
4: On pressing ‘Go,' the user will be warned that importing reports can overwrite existing reports if they share the same name. Select ‘I confirm.'
5: The user will be prompted with a text informing you that new or backed-up reports have been successfully imported.